package/sdl2: enable opengl support
authorRomain Naour <romain.naour@gmail.com>
Sun, 26 Feb 2017 16:48:53 +0000 (17:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Feb 2017 20:05:09 +0000 (21:05 +0100)
OpenGl support mean GLX so it require X11 support.
Select automatically BR2_PACKAGE_SDL2_X11 to enable minimal X11
libraries support (libx11 and libxext).

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sdl2/Config.in
package/sdl2/sdl2.mk

index 8fc14ee73720005968190957f28bdaf3ab49f4a2..6345133c42d96fa66394e82f162f2a4d1646356d 100644 (file)
@@ -29,6 +29,17 @@ comment "X11 video driver needs X.org"
        depends on !BR2_PACKAGE_XORG7
        depends on BR2_USE_MMU
 
+config BR2_PACKAGE_SDL2_OPENGL
+       bool "OpenGL (GLX)"
+       depends on BR2_PACKAGE_HAS_LIBGL
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_USE_MMU # X11 video driver
+       select BR2_PACKAGE_SDL2_X11
+
+comment "OpenGL support needs X11 and an OpenGL provider"
+       depends on BR2_USE_MMU
+       depends on !BR2_PACKAGE_HAS_LIBGL || !BR2_PACKAGE_XORG7
+
 endif
 
 comment "sdl2 needs a toolchain w/ dynamic library"
index 2ec12e639e301fc880b92955ed59446bcf14bd0d..3f210f8d6038dace9c9b4813449239be9da33f89 100644 (file)
@@ -18,7 +18,6 @@ SDL2_CONF_OPTS += \
        --disable-esd \
        --disable-dbus \
        --disable-pulseaudio \
-       --disable-video-opengl \
        --disable-video-opengles \
        --disable-video-wayland
 
@@ -99,6 +98,13 @@ else
 SDL2_CONF_OPTS += --disable-video-x11 --without-x
 endif
 
+ifeq ($(BR2_PACKAGE_SDL2_OPENGL),y)
+SDL2_CONF_OPTS += --enable-video-opengl
+SDL2_DEPENDENCIES += libgl
+else
+SDL2_CONF_OPTS += --disable-video-opengl
+endif
+
 ifeq ($(BR2_PACKAGE_TSLIB),y)
 SDL2_DEPENDENCIES += tslib
 SDL2_CONF_OPTS += --enable-input-tslib