circus: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 5 Jul 2016 14:41:33 +0000 (16:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 15:26:35 +0000 (17:26 +0200)
Reviewed-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
[Thomas: minor tweaks to Config.in.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/circus/Config.in [new file with mode: 0644]
package/circus/circus.hash [new file with mode: 0644]
package/circus/circus.mk [new file with mode: 0644]

index 6cc1d3e5c2917c960cff63c090f712e6894750e8..4d3d20290db0da5e83647eb382743259b91eb6bb 100644 (file)
@@ -1635,6 +1635,7 @@ menu "System tools"
        source "package/attr/Config.in"
        source "package/audit/Config.in"
        source "package/bootutils/Config.in"
+       source "package/circus/Config.in"
        source "package/coreutils/Config.in"
        source "package/cpuload/Config.in"
        source "package/dcron/Config.in"
diff --git a/package/circus/Config.in b/package/circus/Config.in
new file mode 100644 (file)
index 0000000..e696f25
--- /dev/null
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_CIRCUS
+       bool "circus"
+       depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+       depends on BR2_USE_WCHAR # pyzmq -> zeromq
+       depends on BR2_INSTALL_LIBSTDCPP # pyzmq -> zeromq
+       depends on BR2_TOOLCHAIN_HAS_THREADS # pyzmq -> zeromq
+       select BR2_PACKAGE_PYTHON_IOWAIT # runtime
+       select BR2_PACKAGE_PYTHON_PSUTIL # runtime
+       select BR2_PACKAGE_PYTHON_PYZMQ # runtime
+       select BR2_PACKAGE_PYTHON_TORNADO # runtime
+       select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
+       help
+         Circus is a program that will let you run and watch multiple
+         processes and sockets.
+
+         https://circus.readthedocs.org/en/latest/
+
+comment "circus needs Python and a toolchain w/ C++, wchar, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+               !BR2_TOOLCHAIN_HAS_THREADS || \
+               !(BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3)
diff --git a/package/circus/circus.hash b/package/circus/circus.hash
new file mode 100644 (file)
index 0000000..728cad5
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/circus/json, sha256 locally computed
+md5    cddd4a8844907d8b6b402ca9c713d176  circus-0.13.0.tar.gz
+sha256 6201800a5fb05144b5e6c5ac9eb901b914305e8beaeb01f8edf54ab6ab1a295a  circus-0.13.0.tar.gz
diff --git a/package/circus/circus.mk b/package/circus/circus.mk
new file mode 100644 (file)
index 0000000..a7693bd
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# circus
+#
+################################################################################
+
+CIRCUS_VERSION = 0.13.0
+CIRCUS_SOURCE = circus-$(CIRCUS_VERSION).tar.gz
+CIRCUS_SITE = https://pypi.python.org/packages/source/c/circus
+CIRCUS_SETUP_TYPE = setuptools
+CIRCUS_LICENSE = Apache-2.0
+CIRCUS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))