cmake: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Mar 2010 21:31:26 +0000 (22:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:03:55 +0000 (11:03 +0200)
Only compilation for the host is supported, why explains why we don't
have a Config.in and the corresponding BR2_PACKAGE_CMAKE option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cmake/cmake.mk [new file with mode: 0644]

diff --git a/package/cmake/cmake.mk b/package/cmake/cmake.mk
new file mode 100644 (file)
index 0000000..42d4ff5
--- /dev/null
@@ -0,0 +1,20 @@
+CMAKE_VERSION=2.8.0
+CMAKE_SOURCE=cmake-$(CMAKE_VERSION).tar.gz
+CMAKE_SITE=http://www.cmake.org/files/v2.8/
+
+define HOST_CMAKE_CONFIGURE_CMDS
+ (cd $(@D); \
+   ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
+ )
+endef
+
+define HOST_CMAKE_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_CMAKE_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+endef
+
+$(eval $(call GENTARGETS,package,cmake))
+$(eval $(call GENTARGETS,package,cmake,host))
\ No newline at end of file