- make sure to download fakeroot if needed
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 6 Apr 2007 16:36:48 +0000 (16:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 6 Apr 2007 16:36:48 +0000 (16:36 -0000)
Makefile
package/fakeroot/Config.in
package/fakeroot/fakeroot.mk
target/cpio/Config.in
target/cramfs/Config.in
target/ext2/Config.in
target/iso9660/Config.in
target/jffs2/Config.in
target/squashfs/Config.in
target/tar/Config.in

index 6cb05d30c8d501762d4390bab0fd55a3e37f86bb..5a30f26cdf88f1c90a396cf174f7c03da4f63ced 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -119,7 +119,7 @@ $(TARGET_DIR):
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
 
-source: $(TARGETS_SOURCE)
+source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
 #############################################################
 #
index f9aa1ebf8588c720a9d4539a9d3f7e9770407a42..caab206df0cd1a2f6e59d4664f42015d79527dda 100644 (file)
@@ -5,3 +5,8 @@ config BR2_PACKAGE_FAKEROOT
          Run commands in an environment faking root privileges.
 
          http://joostje.op.het.net/fakeroot/
+
+# dummy for fakeroot-source
+config BR2_HOST_FAKEROUTE
+       bool
+       default n
index 9a55fd1fc325796b98d122ab9d43a9645dfdec8c..18f577e4a74ff16cb58e8b503f6ee63ade768558 100644 (file)
@@ -122,3 +122,7 @@ fakeroot-dirclean:
 ifeq ($(strip $(BR2_PACKAGE_FAKEROOT)),y)
 TARGETS+=fakeroot
 endif
+
+ifeq ($(strip $(BR2_HOST_FAKEROUTE)),y)
+HOST_SOURCE+=fakeroot-source
+endif
index 0de70f964a2c29144dd9592e704985f42b99fd89..7f1af40776560c55b67f631a3a3abb5b934907b4 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_CPIO
-       bool "cpio the root filesystem"
-       default n
-       help
-         Build a cpio archive of the root filesystem
+       bool "cpio the root filesystem"
+       default n
+       select BR2_HOST_FAKEROUTE
+       help
+         Build a cpio archive of the root filesystem
 
index 917e99d11830401b0f2bb1998485a33302df12a7..d7c1dea683853c56b198b5b1467b24c029d6c9ba 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_CRAMFS
        bool "cramfs root filesystem"
        default n
+       select BR2_HOST_FAKEROUTE
        help
          Build a cramfs root filesystem
 
index b84ead3cd2343fc58a8fdce6d1a24a44e2281e07..70589974a8e7ea486833458eef496bf33f9399f9 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_EXT2
        bool "ext2 root filesystem"
        default y
+       select BR2_HOST_FAKEROUTE
        help
          Build an ext2 root filesystem
 
index ecfcd396273ed9c4576ab89a9dccb58c23c3d2a9..7b3575111b5c74e122e3a4ba7fa41493e6f4dc15 100644 (file)
@@ -4,6 +4,7 @@ config BR2_TARGET_ROOTFS_ISO9660
        depends on BR2_i386
        select BR2_TARGET_ROOTFS_EXT2
        select BR2_TARGET_GRUB
+       select BR2_HOST_FAKEROUTE
        help
          Build a bootable iso9660 image
 
index c7c8e9f0cfe72fc28b2e7d29d7227e32370e773a..2d4e7a455229e99fe4f126fa509fd30e76c2554b 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_JFFS2
        bool "jffs2 root filesystem"
        default n
+       select BR2_HOST_FAKEROUTE
        select BR2_PACKAGE_MTD
        help
          Build a jffs2 root filesystem
index 733eea825e8f96b6b1424f284778cd043bddde93..34b16ad63f9ba48a3a2e26c5320a82767c444634 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_SQUASHFS
        bool "squashfs root filesystem"
        default n
+       select BR2_HOST_FAKEROUTE
        help
          Build a squashfs root filesystem
 
index 9a0b80560cbe0e050ebe7a3b3c7071b595ab5a6a..142ac878dd4eee4e6248af046f9318dcfc4d6c06 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_TARGET_ROOTFS_TAR
        bool "tar the root filesystem"
        default n
+       select BR2_HOST_FAKEROUTE
        help
          Build a tar archive of the root filesystem