libxslt: enable compilation on host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 17:12:34 +0000 (18:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 18:31:04 +0000 (19:31 +0100)
Compiling libxcb (from the X.org stack) requires xsltproc on the host,
which is part of libxslt.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxslt/libxslt.mk

index 03c113103c89f502387ac85f8c8bd2dc6faed850..4bf61b54c55b7c034eb96fc19c874d3f638126a9 100644 (file)
@@ -25,7 +25,15 @@ LIBXSLT_CONF_OPT = --with-gnu-ld --enable-shared \
 
 LIBXSLT_DEPENDENCIES = libxml2 $(LIBXSLT_DEPENDENCIES_EXTRA)
 
+HOST_LIBXSLT_CONF_OPT = --enable-shared \
+                       --without-debugging \
+                       --without-python \
+                       --without-threads
+
+HOST_LIBXSLT_DEPENDENCIES = host-libxml2
+
 $(eval $(call AUTOTARGETS,package,libxslt))
+$(eval $(call AUTOTARGETS,package,libxslt,host))
 
 $(LIBXSLT_HOOK_POST_INSTALL):
        $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xslt-config