package/weston: add support for libinput
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 2 Jun 2014 20:27:24 +0000 (22:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Jun 2014 21:15:47 +0000 (23:15 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/weston/weston.mk

index ea632037638290af9228219eaff6e108a460f75a..325cfc75120c241f317006f34183871e11a931ba 100644 (file)
@@ -32,6 +32,13 @@ else
 WESTON_CONF_OPT += --disable-xkbcommon
 endif
 
+ifeq ($(BR2_PACKAGE_LIBINPUT),y)
+WESTON_DEPENDENCIES += libinput
+WESTON_CONF_OPT += --enable-libinput-backend
+else
+WESTON_CONF_OPT += --disable-libinput-backend
+endif
+
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 WESTON_DEPENDENCIES += libunwind
 else