Added local directory as source of kernel code
authorRafal Fabich <rafal.fabich@gmail.com>
Sat, 23 Feb 2013 18:03:30 +0000 (19:03 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2014 10:01:46 +0000 (11:01 +0100)
Add the option to use a local directory as the source for
building the Linux kernel, which can be useful during
kernel development.

Signed-off-by: Rafal Fabich <rafal.fabich@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/Config.in
linux/linux.mk

index 91d4d71c9deaff3a6ff161e819cc983332e31391..0fdc1949e2b6f417e143077bf786ddf70542f67c 100644 (file)
@@ -63,6 +63,12 @@ config BR2_LINUX_KERNEL_CUSTOM_HG
          This option allows Buildroot to get the Linux kernel source
          code from a Mercurial repository.
 
+config BR2_LINUX_KERNEL_CUSTOM_LOCAL
+       bool "Local directory"
+       help
+         This option allows Buildroot to get the Linux kernel source
+         code from a local directory.
+
 endchoice
 
 config BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE
@@ -90,6 +96,12 @@ config BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION
 
 endif
 
+config BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH
+       string "Path to the local directory"
+       depends on BR2_LINUX_KERNEL_CUSTOM_LOCAL
+       help
+         Path to the local directory with the Linux kernel source code.
+
 config BR2_LINUX_KERNEL_VERSION
        string
        default "3.13.1" if BR2_LINUX_KERNEL_LATEST_VERSION
@@ -99,6 +111,7 @@ config BR2_LINUX_KERNEL_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
        default BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION \
                if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG
+       default "custom" if BR2_LINUX_KERNEL_CUSTOM_LOCAL
 
 #
 # Patch selection
index 62033d280b87a2164efb57b9f6c4e2bc3a8293e8..1a81f77c8f58942272eb0c60b93fdbf6364dd4a5 100644 (file)
@@ -9,10 +9,13 @@ LINUX_LICENSE = GPLv2
 LINUX_LICENSE_FILES = COPYING
 
 # Compute LINUX_SOURCE and LINUX_SITE from the configuration
-ifeq ($(LINUX_VERSION),custom)
+ifeq ($(BR2_LINUX_KERNEL_CUSTOM_TARBALL),y)
 LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
 LINUX_SITE = $(patsubst %/,%,$(dir $(LINUX_TARBALL)))
 LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
+else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_LOCAL),y)
+LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH))
+LINUX_SITE_METHOD = local
 else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
 LINUX_SITE_METHOD = git