busybox: add option to specify config fragments
authorFloris Bos <bos@je-eigen-domein.nl>
Tue, 28 Apr 2015 14:34:33 +0000 (16:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 21:50:34 +0000 (23:50 +0200)
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/Config.in
package/busybox/busybox.mk

index b4f949f3eff609f52640e6053992e47b4676f10d..6847a60e839ca03595e82d6b719eba434eba61cd 100644 (file)
@@ -20,6 +20,12 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
 
          Most people will just use the default BusyBox configuration file.
 
+config BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES
+       string "Additional BusyBox configuration fragment files"
+       help
+         A space-separated list of configuration fragment files,
+         that will be merged to the main BusyBox configuration file.
+
 config BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        bool "Show packages that are also provided by busybox"
        help
index 1ce508a6b5b37f8d62e8ce4853a2d330800bb680..090e17469072971d96a59cdf8c071844e23330e0 100644 (file)
@@ -46,6 +46,7 @@ ifndef BUSYBOX_CONFIG_FILE
 endif
 
 BUSYBOX_KCONFIG_FILE = $(BUSYBOX_CONFIG_FILE)
+BUSYBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES))
 BUSYBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig
 BUSYBOX_KCONFIG_OPTS = $(BUSYBOX_MAKE_OPTS)