Revert "toolchain: handle toolchains with multiple ld*.so.* files"
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 26 Aug 2021 12:19:09 +0000 (14:19 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 26 Aug 2021 12:20:23 +0000 (14:20 +0200)
This breaks some existing external toolchains. Since we're very close to
a release, don't try to fix it, but instead simply revert.

This reverts commit 6f911a17257d945eb3cb5c9c9a966f0e5fca0842.

Fixes: http://autobuild.buildroot.net/results/afe/afe44f4b6a3c53e5864cfb10b04529011e72cf5c/
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
toolchain/helpers.mk

index 5ed149d57d31a162993e6750c741fd6ed28843f0..dfb2581ed5edda39474a735f3c3ea9ef358ddd47 100644 (file)
@@ -135,8 +135,10 @@ copy_toolchain_sysroot = \
                        $(call simplify_symlink,$$i,$(STAGING_DIR)) ; \
                done ; \
        fi ; \
-       if ! find -wholename $(STAGING_DIR)'/lib/ld*.so.*' > /dev/null; then \
-               find -wholename $${ARCH_SYSROOT_DIR}'/lib/ld*.so.*' -print0 | xargs -0 -I % cp % $(STAGING_DIR)/lib/; \
+       if [ ! -e $(STAGING_DIR)/lib/ld*.so.* ]; then \
+               if [ -e $${ARCH_SYSROOT_DIR}/lib/ld*.so.* ]; then \
+                       cp -a $${ARCH_SYSROOT_DIR}/lib/ld*.so.* $(STAGING_DIR)/lib/ ; \
+               fi ; \
        fi ; \
        if [ `readlink -f $${SYSROOT_DIR}` != `readlink -f $${ARCH_SYSROOT_DIR}` ] ; then \
                if [ ! -d $${ARCH_SYSROOT_DIR}/usr/include ] ; then \