gstreamer1: explicitly disable introspection
authorAdam Duskett <aduskett@gmail.com>
Sun, 29 Jul 2018 19:19:19 +0000 (15:19 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 31 Jul 2018 20:56:22 +0000 (22:56 +0200)
To get GStreamer ready for introspection, we must first explicitly
disable gstreamer1, plugins base and plugins bad from using
introspection. If not, adding the gobject-introspection will result in
these packages failing to build because setting the
_GIR_EXTRA_LIBS_PATH variable is required.

The other gstreamer1 packages do not require setting the
_GIR_EXTRA_LIBS_PATH variable.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk
package/gstreamer1/gstreamer1/gstreamer1.mk

index c9bf2b2fb7e60354cf51bfd0aeef84181d6b3d7b..4fd5b3fc8f52db8ed878f94c5356dee5bec00768 100644 (file)
@@ -21,7 +21,8 @@ GST1_PLUGINS_BAD_CONF_OPTS = \
        --disable-winks \
        --disable-android_media \
        --disable-apple_media \
-       --disable-acm
+       --disable-acm \
+       --disable-introspection
 
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_BAD_CONF_OPTS += \
index 36440ef5fa0790c2c457b1b135ba4dc16dc0c82c..10b1fec4390ae8c155a826f0f0d2caa96d2143bb 100644 (file)
@@ -14,7 +14,8 @@ GST1_PLUGINS_BASE_LICENSE = LGPL-2.0+, LGPL-2.1+
 # gio_unix_2_0 is only used for tests
 GST1_PLUGINS_BASE_CONF_OPTS = \
        --disable-examples \
-       --disable-valgrind
+       --disable-valgrind \
+       --disable-introspection
 
 # Options which require currently unpackaged libraries
 GST1_PLUGINS_BASE_CONF_OPTS += \
index 092d6cb82ec7de7e8d39f95ebcb240d491c62902..26316e73cdfb01adb95bf4dbb55148f4caccf6fb 100644 (file)
@@ -17,6 +17,7 @@ GSTREAMER1_CONF_OPTS = \
        --disable-failing-tests \
        --disable-valgrind \
        --disable-benchmarks \
+       --disable-introspection \
        $(if $(BR2_PACKAGE_GSTREAMER1_CHECK),,--disable-check) \
        $(if $(BR2_PACKAGE_GSTREAMER1_TRACE),,--disable-trace) \
        $(if $(BR2_PACKAGE_GSTREAMER1_PARSE),,--disable-parse) \