perl-dbi: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:51 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Aug 2018 21:31:21 +0000 (23:31 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-dbi/Config.in [new file with mode: 0644]
package/perl-dbi/perl-dbi.hash [new file with mode: 0644]
package/perl-dbi/perl-dbi.mk [new file with mode: 0644]

index ab25a63677a9a23d753bbc5c627046dc66fb1ea6..3c80c20cf0bf46b8795f2eadbf5db6dcd9dd2040 100644 (file)
@@ -486,6 +486,7 @@ F:  package/perl-astro-suntime/
 F:     package/perl-class-std/
 F:     package/perl-data-uuid/
 F:     package/perl-date-manip/
+F:     package/perl-dbi/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index 461a004ef342d64c501ae7e231be5475cea5918f..8d80c415606c093b895279ed4e00b1b8ef2a8235 100644 (file)
@@ -676,6 +676,7 @@ menu "Perl libraries/modules"
        source "package/perl-data-uuid/Config.in"
        source "package/perl-date-manip/Config.in"
        source "package/perl-datetime-tiny/Config.in"
+       source "package/perl-dbi/Config.in"
        source "package/perl-digest-hmac/Config.in"
        source "package/perl-digest-md5/Config.in"
        source "package/perl-digest-sha1/Config.in"
diff --git a/package/perl-dbi/Config.in b/package/perl-dbi/Config.in
new file mode 100644 (file)
index 0000000..069669b
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PERL_DBI
+       bool "perl-dbi"
+       depends on !BR2_STATIC_LIBS
+       help
+         Database independent interface for Perl
+
+         http://dbi.perl.org/
+
+comment "perl-dbi needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-dbi/perl-dbi.hash b/package/perl-dbi/perl-dbi.hash
new file mode 100644 (file)
index 0000000..1d0b7e9
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    e77fd37fcf77fc88fde029c1b75ded54 DBI-1.641.tar.gz
+sha256 5509e532cdd0e3d91eda550578deaac29e2f008a12b64576e8c261bb92e8c2c1 DBI-1.641.tar.gz
+
+# computed by scancpan
+sha256 33453c8b0d8d474a42669ac702a13c20f39c91a34b3df4e6ca778fc2f0f711c7 LICENSE
diff --git a/package/perl-dbi/perl-dbi.mk b/package/perl-dbi/perl-dbi.mk
new file mode 100644 (file)
index 0000000..f7ae6ca
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# perl-dbi
+#
+################################################################################
+
+PERL_DBI_VERSION = 1.641
+PERL_DBI_SOURCE = DBI-$(PERL_DBI_VERSION).tar.gz
+PERL_DBI_SITE = $(BR2_CPAN_MIRROR)/authors/id/T/TI/TIMB
+PERL_DBI_LICENSE = Artistic or GPL-1.0+
+PERL_DBI_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))