Fix build reproducibility in Make 3.82
authorJérôme Pouiller <jezz@sysmic.org>
Tue, 3 Sep 2013 08:45:41 +0000 (10:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 6 Sep 2013 21:27:42 +0000 (23:27 +0200)
Make 3.82 no longer sort the result of wildcards (see
http://comments.gmane.org/gmane.comp.gnu.make.bugs/4260). This may break
build reproducibility.

This patch sort results of wildcards to ensure reproducibility.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
14 files changed:
Makefile
boot/common.mk
docs/manual/manual.mk
fs/common.mk
linux/linux.mk
package/efl/efl.mk
package/freescale-imx/freescale-imx.mk
package/gcc/gcc.mk
package/gtk2-themes/gtk2-themes.mk
package/matchbox/matchbox.mk
package/opengl/opengl.mk
package/qt5/qt5.mk
package/x11r7/x11r7.mk
support/dependencies/dependencies.mk

index 0d7476a4c63afcabd540d0f0db455e5889088bf6..3ca7313942d054bdb5c3254803edb498fb753c0e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -333,7 +333,7 @@ ifneq ($(PACKAGE_OVERRIDE_FILE),)
 -include $(PACKAGE_OVERRIDE_FILE)
 endif
 
-include package/*/*.mk
+include $(sort $(wildcard package/*/*.mk))
 
 include boot/common.mk
 include linux/linux.mk
index b315fe839370cb8d52a1f206d07d5b3a8f420194..3021e51949234fd9cbf4ba1a5d09d398e3f012a8 100644 (file)
@@ -1 +1 @@
-include boot/*/*.mk
+include $(sort $(wildcard boot/*/*.mk))
index 4906bc871f1e5b7ec2b9ed6b2bcd2823df255aa7..bcbedad572f970c314b36abb01eee49eb149b41b 100644 (file)
@@ -53,5 +53,5 @@ $(1)-clean:
 .PHONY: $(1) $(1)-clean manual-update-lists
 endef
 
-MANUAL_SOURCES = $(wildcard docs/manual/*.txt) $(wildcard docs/images/*)
+MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
 $(eval $(call GENDOC,manual))
index 36da2dd6455f4cd5c2c51252543e821cc83303bd..4dab7ea28baba822c5e85e2c180630717b4b4846 100644 (file)
@@ -94,4 +94,4 @@ define ROOTFS_TARGET
 $(call ROOTFS_TARGET_INTERNAL,$(1),$(call UPPERCASE,$(1)))
 endef
 
-include fs/*/*.mk
+include $(sort $(wildcard fs/*/*.mk))
index 025fd51aba9fc3b0d58e0fac593f17d451aed7e6..8508a542426e6d36a94cd11fe381d166fef82ab9 100644 (file)
@@ -281,7 +281,7 @@ define LINUX_INSTALL_TARGET_CMDS
        $(LINUX_INSTALL_HOST_TOOLS)
 endef
 
-include linux/linux-ext-*.mk
+include $(sort $(wildcard linux/linux-ext-*.mk))
 
 $(eval $(generic-package))
 
index f284c93be7a30a3f1fa72404f5de36cbb36f33a4..1de68cf8fe64ae8a773ad61f6f676be5d1924dc6 100644 (file)
@@ -1,3 +1,3 @@
 EFL_VERSION = 1.7.7
 
-include package/efl/*/*.mk
+include $(sort $(wildcard package/efl/*/*.mk))
index 9f63ce34236e5bcbe4f2a5988c77075dde7f9ffb..c8f99b6348dd250e77b55f1f2899da0316c5a3dd 100644 (file)
@@ -9,5 +9,5 @@ FREESCALE_IMX_VERSION = 1.1.0
 # No official download site from freescale, just this mirror
 FREESCALE_IMX_MIRROR_SITE   = http://download.ossystems.com.br/bsp/freescale/source
 
-include package/freescale-imx/*/*.mk
+include $(sort $(wildcard package/freescale-imx/*/*.mk))
 
index ccba5e1586c085debb19b6b6fc5af803eef2c8d2..6654b5167464bfa1fb72e00a481f144ebe670266 100644 (file)
@@ -220,4 +220,4 @@ HOST_GCC_COMMON_CONF_OPT += \
        --with-long-double-128
 endif
 
-include package/gcc/*/*.mk
+include $(sort $(wildcard package/gcc/*/*.mk))
index 6f31c6da981696a0721bafc8c1236290732c0847..fc66698a1dddf24cefe41329e03f66ec074b2259 100644 (file)
@@ -1 +1 @@
-include package/gtk2-themes/*/*.mk
+include $(sort $(wildcard package/gtk2-themes/*/*.mk))
index abda91559c89acf1f9b10ab786a28e399f6b7fb6..fff4add34b240d178ad545f99d17eb2aeaf35739 100644 (file)
@@ -1,4 +1,4 @@
 ifeq ($(BR2_PACKAGE_MATCHBOX),y)
-include package/matchbox/*/*.mk
+include $(sort $(wildcard package/matchbox/*/*.mk))
 TARGETS+=matchbox-lib matchbox-wm
 endif
index 68df3b171bf97bc0c1c64a8150963f7b3ad94b83..abf96d5c70df7d92742b9a235a17972c89b501d8 100644 (file)
@@ -1 +1 @@
-include package/opengl/*/*.mk
+include $(sort $(wildcard package/opengl/*/*.mk))
index 9e71c83ce3a07c6998f8ea05440bcb772efceeda..fce0ca38483f5d14dc2c41b8d94b1a2be9dd0f37 100644 (file)
@@ -1,6 +1,6 @@
 QT5_VERSION = 5.0.2
 QT5_SITE = http://download.qt-project.org/archive/qt/5.0/$(QT5_VERSION)/submodules/
-include package/qt5/*/*.mk
+include $(sort $(wildcard package/qt5/*/*.mk))
 
 define QT5_LA_PRL_FILES_FIXUP
        for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
index ea0363f6a0420e9d3c771d54f080560ec6c5f68c..85ecbc5968786b366cc332aeb07d2790f36c6b4b 100644 (file)
@@ -1 +1 @@
-include package/x11r7/*/*.mk
+include $(sort $(wildcard package/x11r7/*/*.mk))
index 4a220e0e02e0d8b883ba4bb1bc82a7396fc9ae08..149b8e5dccb01b0a711605788534765118d8db1c 100644 (file)
@@ -14,7 +14,7 @@ DEPENDENCIES_HOST_PREREQ :=
 define suitable-host-package
 $(shell support/dependencies/check-host-$(1).sh $(2))
 endef
--include support/dependencies/check-host-*.mk
+-include $(sort $(wildcard support/dependencies/check-host-*.mk))
 
 ifeq ($(BR2_STRIP_sstrip),y)
 DEPENDENCIES_HOST_PREREQ+=host-sstrip