package/vlc: add optional dependency to gst1-plugins-base
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:26 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:16 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 91e96516acac0e30bd20ca7bce6bbedc3fd9ff6b..6643d6fd8d1ad7b498b3d9e6c0f6ede59a158183 100644 (file)
@@ -59,7 +59,6 @@ VLC_CONF_OPTS += \
        --disable-fluidsynth \
        --disable-gme \
        --disable-goom \
-       --disable-gst-decode \
        --disable-harfbuzz \
        --disable-jack \
        --disable-jpeg \
@@ -181,6 +180,13 @@ else
 VLC_CONF_OPTS += --disable-freerdp
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE),y)
+VLC_CONF_OPTS += --enable-gst-decode
+VLC_DEPENDENCIES += gst1-plugins-base
+else
+VLC_CONF_OPTS += --disable-gst-decode
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
 VLC_DEPENDENCIES += libgl
 endif