package/qemu: disable bzip2 for the host variant
authorRomain Naour <romain.naour@gmail.com>
Mon, 6 Apr 2020 14:21:58 +0000 (16:21 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 18:18:10 +0000 (20:18 +0200)
bzip2 support is needed for reading bzip2-compressed dmg images.

But the host-bzip2 is missing from host qemu package dependency,
so the qemu build system will try to detect automatically the
external libbzip2 libraries installed on the host.

$ ldd output/host/bin/qemu-system-aarch64
[...]
libbz2.so.1 => /lib64/libbz2.so.1
or
libbz2.so.1.0 => output/host/lib/libbz2.so.1.0
if host-bzip2 is built before host-qemu.

Disable explicitely bzip2 options to improve the build
reproducibility.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qemu/qemu.mk

index b8904ffe186ceb842b6ed776acdbb40a2b7a1ccb..06841a56d03c0eae8fded033a86e96570bf04b49 100644 (file)
@@ -303,6 +303,7 @@ define HOST_QEMU_CONFIGURE_CMDS
                --extra-cflags="$(HOST_QEMU_CFLAGS)" \
                --extra-ldflags="$(HOST_LDFLAGS)" \
                --python=$(HOST_DIR)/bin/python3 \
+               --disable-bzip2 \
                --disable-libssh \
                --disable-vnc-jpeg \
                --disable-vnc-png \