package/php: fix building pcre extension
authorAdam Duskett <Aduskett@gmail.com>
Fri, 28 Dec 2018 16:56:34 +0000 (11:56 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 10 Jan 2019 22:03:38 +0000 (23:03 +0100)
The configure option "--with-pcre-regex=$(STAGING_DIR)/usr" is broken.
PHP will  prepend $(STAGING_DIR)/usr to the paths, which will cause a
failure because it won't be able to find pcre, and will then fallback to
searching for pcre2, which won't be installed.

Removing "=$(STAGING_DIR)/usr" from --with-pcre-regex fixes the issue.

Fixes:
  http://autobuild.buildroot.net/results/586/586f56e8fcf2d2bbbd3bdf69b1c3befff7ce8bbf
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Tested-by: Mark Corbin <mark.corbin@embecosm.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/php/php.mk

index fd428e192a4a4537bf58dbbce797e79b1b1244b7..7d7d78353bc95a97f3cd168993313121f77eb7ca 100644 (file)
@@ -244,7 +244,7 @@ PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
 
 ### Use external PCRE if it's available
 ifeq ($(BR2_PACKAGE_PCRE),y)
-PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
+PHP_CONF_OPTS += --with-pcre-regex
 PHP_DEPENDENCIES += pcre
 else
 # The bundled pcre library is not configurable through ./configure options,