cpanminus: remove it
authorFrancois Perrad <fperrad@gmail.com>
Mon, 10 Feb 2014 12:23:15 +0000 (13:23 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 10 Feb 2014 18:50:12 +0000 (19:50 +0100)
cpanminus was marked as broken, now it becomes useless with the Perl infrastructure.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/cpanminus/Config.in [deleted file]
package/cpanminus/cpanminus.mk [deleted file]

index 6c3e769149085d55e37f4ac601101b0a85461cf8..fca61d6752921a3d1015b063f6eaa1c48d86cd68 100644 (file)
@@ -391,7 +391,6 @@ source "package/nodejs/Config.in"
 source "package/perl/Config.in"
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
-source "package/cpanminus/Config.in"
 endmenu
 endif
 source "package/php/Config.in"
diff --git a/package/cpanminus/Config.in b/package/cpanminus/Config.in
deleted file mode 100644 (file)
index b10d211..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-config BR2_PACKAGE_CPANMINUS
-       bool "cpanminus"
-       # Requires host-qemu, which cannot work properly due to kernel
-       # headers mismatch between the build environment and the
-       # target.
-       depends on BR2_BROKEN
-       help
-         cpanminus is a script to get, unpack, build and install Perl modules
-         from CPAN.
-
-         Why? It's dependency free, requires zero configuration, and stands
-         alone. When running, it requires only 10MB of RAM.
-
-         http://github.com/miyagawa/cpanminus
-
-if BR2_PACKAGE_CPANMINUS
-
-config BR2_PACKAGE_CPANMINUS_MIRROR
-       string "mirror"
-       help
-         Specifies the base URL for the CPAN mirror to use,
-         such as http://cpan.cpantesters.org/.
-
-config BR2_PACKAGE_CPANMINUS_MODULES
-       string "Perl modules from CPAN"
-       default "Curses::UI"
-       help
-         List of space-separated Perl modules to install from CPAN.
-
-         Examples: Try::Tiny Dancer YAML Moo
-
-         Install the listed modules and their dependencies.
-
-config BR2_PACKAGE_CPANMINUS_NATIVE_DEPENDENCIES
-       string "native dependencies"
-       default "ncurses"
-       help
-         Some XS modules require native libraries.
-
-endif
diff --git a/package/cpanminus/cpanminus.mk b/package/cpanminus/cpanminus.mk
deleted file mode 100644 (file)
index b315388..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-################################################################################
-#
-# cpanminus
-#
-################################################################################
-
-CPANMINUS_VERSION = 1.6109
-CPANMINUS_SOURCE = $(CPANMINUS_VERSION).tar.gz
-CPANMINUS_SITE = https://github.com/miyagawa/cpanminus/archive
-CPANMINUS_DEPENDENCIES = host-qemu perl $(call qstrip,$(BR2_PACKAGE_CPANMINUS_NATIVE_DEPENDENCIES))
-
-CPANMINUS_RUN_PERL = $(QEMU_USER) $(STAGING_DIR)/usr/bin/perl
-CPANMINUS_ARCHNAME = $(shell $(CPANMINUS_RUN_PERL) -MConfig -e "print Config->{archname}")
-CPANMINUS_PERL_LIB      = $(STAGING_DIR)/usr/lib/perl5/$(PERL_VERSION)
-CPANMINUS_PERL_SITELIB  = $(TARGET_DIR)/usr/lib/perl5/site_perl/$(PERL_VERSION)
-CPANMINUS_PERL_ARCHLIB  = $(CPANMINUS_PERL_LIB)/$(CPANMINUS_ARCHNAME)
-CPANMINUS_PERL_SITEARCH = $(CPANMINUS_PERL_SITELIB)/$(CPANMINUS_ARCHNAME)
-CPANMINUS_PERL5LIB = $(CPANMINUS_PERL_SITEARCH):$(CPANMINUS_PERL_SITELIB):$(CPANMINUS_PERL_ARCHLIB):$(CPANMINUS_PERL_LIB)
-ifneq ($(BR2_PACKAGE_CPANMINUS_MIRROR),"")
-    CPANMINUS_MIRROR = --mirror $(call qstrip,$(BR2_PACKAGE_CPANMINUS_MIRROR)) --mirror-only
-endif
-CPANMINUS_MODULES = $(call qstrip,$(BR2_PACKAGE_CPANMINUS_MODULES))
-
-ifneq ($(CPANMINUS_MODULES),)
-define CPANMINUS_INSTALL_TARGET_CMDS
-       echo "#!/bin/sh"                                                        > $(@D)/run_perl
-       echo "PERL5LIB=$(CPANMINUS_PERL5LIB) $(CPANMINUS_RUN_PERL) \"\$$@\""    >>$(@D)/run_perl
-       chmod +x $(@D)/run_perl
-       PERL5LIB=$(CPANMINUS_PERL5LIB) \
-       PERL_MM_OPT="DESTDIR=$(TARGET_DIR) PERL=$(@D)/run_perl PERL_LIB=$(CPANMINUS_PERL_LIB) PERL_ARCHLIB=$(CPANMINUS_PERL_ARCHLIB)" \
-       PERL_MB_OPT="--destdir $(TARGET_DIR)" \
-       RUN_PERL="$(@D)/run_perl" \
-       $(CPANMINUS_RUN_PERL) $(@D)/cpanm \
-               --perl=$(@D)/run_perl \
-               --notest \
-               --no-man-pages \
-               $(CPANMINUS_MIRROR) \
-               $(call qstrip,$(BR2_PACKAGE_CPANMINUS_MODULES))
-       -find $(CPANMINUS_PERL_SITELIB) -type f -name *.bs -exec rm -f {} \;
-endef
-else
-define CPANMINUS_INSTALL_TARGET_CMDS
-       @echo "No modules to install"
-endef
-endif
-
-$(eval $(generic-package))