pkg-autotools: search in the entire source directory for ltmain.sh
authorWaldemar Brodkorb <wbx@openadk.org>
Wed, 7 Dec 2016 18:41:20 +0000 (19:41 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 7 Dec 2016 19:03:48 +0000 (20:03 +0100)
Fixes static linking of berkeleydb package, where ltmain.sh
is not in the sub-directory that contains configure.
Always search the complete source directory.

Fixes:
 http://autobuild.buildroot.net/results/f0a96f671644d9f9efcf245b354affdc84f7d7da

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-autotools.mk

index 00822e2a9d4f259a06ec74a98581b1ccc85e25a0..f7b848888be114d3e8486ce8bbaf9865fc1b9847 100644 (file)
@@ -59,7 +59,7 @@ endef
 #
 define LIBTOOL_PATCH_HOOK
        @$(call MESSAGE,"Patching libtool")
-       $(Q)for i in `find $($(PKG)_SRCDIR) -name ltmain.sh`; do \
+       $(Q)for i in `find $($(PKG)_DIR) -name ltmain.sh`; do \
                ltmain_version=`sed -n '/^[ \t]*VERSION=/{s/^[ \t]*VERSION=//;p;q;}' $$i | \
                sed -e 's/\([0-9]*\.[0-9]*\).*/\1/' -e 's/\"//'`; \
                ltmain_patchlevel=`sed -n '/^[ \t]*VERSION=/{s/^[ \t]*VERSION=//;p;q;}' $$i | \