iproute2: bump to version 2.6.37 + fixes
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Jan 2011 17:41:25 +0000 (14:41 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 10 Jan 2011 23:20:34 +0000 (00:20 +0100)
Bump to version 2.6.37
Add iptables support when it's available.
ATM support requires linux-atm for which we don't have a package yet.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/iproute2/iproute2.mk

index 0f99894e52d39ebefc4b163d971c550566004721..c3e96509d615f3c4d9e188b1f33ff8fbb93464ca 100644 (file)
@@ -4,19 +4,29 @@
 #
 #############################################################
 
-IPROUTE2_VERSION = 2.6.35
+IPROUTE2_VERSION = 2.6.37
 IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.bz2
 IPROUTE2_SITE = http://devresources.linuxfoundation.org/dev/iproute2/download
 IPROUTE2_TARGET_SBINS = ctstat genl ifstat ip lnstat nstat routef routel rtacct rtmon rtpr rtstat ss tc
 
+# If we've got iptables enable xtables support for tc
+ifeq ($(BR2_PACKAGE_IPTABLES),y)
+IPROUTE2_DEPENDENCIES += iptables
+define IPROUTE2_WITH_IPTABLES
+       # Makefile is busted so it never passes IPT_LIB_DIR properly
+       $(SED) "s/-DIPT/-DXT/" $(IPROUTE2_DIR)/tc/Makefile
+       echo "TC_CONFIG_XT:=y" >>$(IPROUTE2_DIR)/Config
+endef
+endif
+
 define IPROUTE2_CONFIGURE_CMDS
        # Use kernel headers
        rm -r $(IPROUTE2_DIR)/include/netinet
        # arpd needs berkeleydb
        $(SED) "/^TARGETS=/s: arpd : :" $(IPROUTE2_DIR)/misc/Makefile
        $(SED) "s:-O2:$(TARGET_CFLAGS):" $(IPROUTE2_DIR)/Makefile
-       ( cd $(@D); ./configure )
-       echo "IPT_LIB_DIR=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
+       echo "IPT_LIB_DIR:=/usr/lib/xtables" >>$(IPROUTE2_DIR)/Config
+       $(IPROUTE2_WITH_IPTABLES)
 endef
 
 define IPROUTE2_BUILD_CMDS