package/parted: add a host variant
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 12 Dec 2013 18:18:42 +0000 (19:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 12 Dec 2013 22:58:39 +0000 (23:58 +0100)
Useful for for-build scripts to call parted, eg. to generate
partition tables and such automatically.

Since the primary goal is to use parted within scripts, we
do not need readline, so it is forcibly disabled.

Also, it does look unlikely that we need to manipulate LVM
volumes, so we forcibly disable support for the device-mapper.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in.host
package/parted/Config.in.host [new file with mode: 0644]
package/parted/parted.mk

index 5fd25703cb76de48b77fc11c72c7680dc1ab560f..34e84bf340c5b6deb76d895fcbc8d3c6a043dbd1 100644 (file)
@@ -10,6 +10,7 @@ source "package/lpc3250loader/Config.in.host"
 source "package/mtools/Config.in.host"
 source "package/omap-u-boot-utils/Config.in.host"
 source "package/openocd/Config.in.host"
+source "package/parted/Config.in.host"
 source "package/sam-ba/Config.in.host"
 source "package/sunxi-tools/Config.in.host"
 source "package/uboot-tools/Config.in.host"
diff --git a/package/parted/Config.in.host b/package/parted/Config.in.host
new file mode 100644 (file)
index 0000000..f5d7acc
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_HOST_PARTED
+       bool "host parted"
+       help
+         parted, the GNU partition resizing program
+
+         http://www.gnu.org/software/parted/
index afb8287f1686f8bd1788e7b9a6a6e3d3de151f48..15e37a8c63f9c3b447dc26beed576e30f8dc845d 100644 (file)
@@ -26,4 +26,10 @@ else
 PARTED_CONF_OPT += --disable-device-mapper
 endif
 
+HOST_PARTED_DEPENDENCIES = host-util-linux
+HOST_PARTED_CONF_OPT += \
+       --without-readline \
+       --disable-device-mapper \
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))