projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
71d3b5c
)
sqlcipher: fix static linking with openssl
author
Peter Korsgaard
<peter@korsgaard.com>
Tue, 25 Nov 2014 14:32:04 +0000
(15:32 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 25 Nov 2014 14:32:04 +0000
(15:32 +0100)
Pass the needed libraries in LIBS instead of LDFLAGS so they end up last on
the linker cmdline, fixing static linking.
Fixes:
http://autobuild.buildroot.net/results/59d/
59d8d7c7f3e0a205503121c1288187471c0ce80f
/
http://autobuild.buildroot.net/results/2ed/
2ed2026bc5502807588a9335bd4c78e0a26c1cd3
/
http://autobuild.buildroot.net/results/cd3/
cd35b24422cf7f8697e81ca7f0dd2f06dfc55997
/
http://autobuild.buildroot.net/results/aa2/
aa24359a0d7d9bb4e00ba96cb80301f59466ab90
/
And many more.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sqlcipher/sqlcipher.mk
patch
|
blob
|
history
diff --git
a/package/sqlcipher/sqlcipher.mk
b/package/sqlcipher/sqlcipher.mk
index 86eebb5c4c689d04452d805625e2a5c445ae3d92..9b4446c49868b30e10f38648d27811dbe43cc5fd 100644
(file)
--- a/
package/sqlcipher/sqlcipher.mk
+++ b/
package/sqlcipher/sqlcipher.mk
@@
-11,14
+11,13
@@
SQLCIPHER_INSTALL_STAGING = YES
SQLCIPHER_CONF_ENV = \
CFLAGS="$(TARGET_CFLAGS) $(SQLCIPHER_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS) $(SQLCIPHER_LDFLAGS)" \
TCLSH_CMD=$(HOST_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
SQLCIPHER_CONF_OPTS = \
--enable-threadsafe
SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
-SQLCIPHER_
LDFLAGS += -lcrypto -lz
+SQLCIPHER_
CONF_ENV += LIBS="-lcrypto -lz"
ifneq ($(BR2_LARGEFILE),y)
# the sqlite configure script fails to define SQLITE_DISABLE_LFS when