fixup things to behave themselves properly.
authorEric Andersen <andersen@codepoet.org>
Thu, 8 Dec 2005 06:39:19 +0000 (06:39 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 8 Dec 2005 06:39:19 +0000 (06:39 -0000)
/me kicks autoconf a few times

package/coreutils/coreutils.mk

index deb9d5d940b2e892f10c5ccd33aa6001d9ec36e5..f1713c4ef7ff2434c17441ce46988dd5380063c2 100644 (file)
@@ -51,7 +51,7 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
                gl_cv_func_working_utimes=yes \
                ac_cv_func_utime_null=yes \
                ac_cv_have_decl_strerror_r=yes \
-               ac_cv_func_strerror_r_char_p=yes \
+               ac_cv_func_strerror_r_char_p=no \
                jm_cv_func_svid_putenv=yes \
                ac_cv_func_getcwd_null=yes \
                ac_cv_func_getdelim=yes \
@@ -59,6 +59,28 @@ $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked
                utils_cv_func_mkstemp_limitations=no \
                utils_cv_func_mkdir_trailing_slash_bug=no \
                ac_cv_func_memcmp_working=yes \
+               ac_cv_have_decl_malloc=yes \
+               gl_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ac_cv_func_calloc_0_nonnull=yes \
+               ac_cv_func_realloc_0_nonnull=yes \
+               jm_cv_func_gettimeofday_clobber=no \
+               am_cv_func_working_getline=yes \
+               gl_cv_func_working_readdir=yes \
+               jm_ac_cv_func_link_follows_symlink=no \
+               utils_cv_localtime_cache=no \
+               ac_cv_struct_st_mtim_nsec=no \
+               gl_cv_func_tzset_clobber=no \
+               gl_cv_func_getcwd_null=yes \
+               gl_cv_func_getcwd_path_max=yes \
+               ac_cv_func_fnmatch_gnu=yes \
+               am_getline_needs_run_time_check=no \
+               am_cv_func_working_getline=yes \
+               gl_cv_func_mkdir_trailing_slash_bug=no \
+               gl_cv_func_mkstemp_limitations=no \
+               ac_cv_func_working_mktime=yes \
+               jm_cv_func_working_re_compile_pattern=yes \
+               ac_use_included_regex=no \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \