avahi: add dependencies in right order
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 1 Oct 2008 10:28:44 +0000 (10:28 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 1 Oct 2008 10:28:44 +0000 (10:28 -0000)
This patch puts gettext and libintl before the avahi targets, thus making sure
they exist before avahi targets are built.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/avahi/avahi.mk

index 48e4bf77c910824c68b342e36ac4f7894e02469f..32d266a5733b27d60e80d292ae8e15e08b23b067 100644 (file)
@@ -180,7 +180,7 @@ endif
                 $(TARGET_DIR)/usr/sbin/avahi-daemon
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
 
-avahi: uclibc libdaemon $(AVAHI_TARGETS) $(if $(BR2_ENABLE_LOCALE),gettext libintl)
+avahi: uclibc libdaemon $(if $(BR2_ENABLE_LOCALE),gettext libintl) $(AVAHI_TARGETS)
 
 avahi-clean:
        -$(MAKE) -C $(AVAHI_DIR) distclean