package/iputils: fix build with thread support disabled
authorPetr Vorel <petr.vorel@gmail.com>
Fri, 2 Aug 2019 15:15:29 +0000 (17:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Aug 2019 15:27:16 +0000 (17:27 +0200)
Fixes:
http://autobuild.buildroot.net/results/10652b7bf6a606f0dd802916006c44abf3e5e059
http://autobuild.buildroot.net/results/9656af1aafbd2624fb75bf5fc1dfa13b6175c10b
http://autobuild.buildroot.net/results/2e170e149b293d40978e158d55dc0102315b9d86

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/iputils/iputils.mk

index cbcce89684930f79c69851a43b13c68ba0838b83..4a065817901faf2254e6ebfa07ee40e3f6b9bdaa 100644 (file)
@@ -49,6 +49,11 @@ IPUTILS_CONF_OPTS += -DUSE_CRYPTO=none
 IPUTILS_CONF_OPTS += -DBUILD_NINFOD=false
 endif
 
+# ninfod requires <pthread.h>
+ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+IPUTILS_CONF_OPTS += -DBUILD_NINFOD=false
+endif
+
 ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
 IPUTILS_CONF_OPTS += -DUSE_GETTEXT=true
 else