beecrypt: fix build failure of C++ code with g++ 4.7
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jun 2012 07:41:51 +0000 (07:41 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Jun 2012 22:20:31 +0000 (00:20 +0200)
This fixes
http://autobuild.buildroot.org/results/5c1e904b201676275465c902ba3c09951973755c/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/beecrypt/beecrypt.mk

index a0187cee6cccc879a1909c8077a4f91311b617cf..7642c1b8e8c114719bbf0d272b6410250b1664d6 100644 (file)
@@ -7,6 +7,13 @@ BEECRYPT_VERSION = 4.2.1
 BEECRYPT_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/beecrypt
 BEECRYPT_AUTORECONF = YES
 BEECRYPT_INSTALL_STAGING = YES
+
+# beecrypt contains C++ code that g++ 4.7 doesn't really
+# like. Upstream does not seem to be really active, so workaround this
+# by passing -fpermissive.
+BEECRYPT_CONF_ENV = \
+       CXXFLAGS="$(TARGET_CXXFLAGS) -fpermissive"
+
 BEECRYPT_CONF_OPT = \
                --without-java \
                --without-python