samba4: add host-python to dependencies
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 16 Mar 2016 14:34:40 +0000 (11:34 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 16 Mar 2016 21:19:36 +0000 (22:19 +0100)
Even though it's inherited by the python dependency it's more clear this
way for graph-depends, since it's used by the waf buildsystem.
And even though we have a hard dependency on python for the distro this
python could ostensibly be 3.x which isn't compatible with the bundled
waf series (1.5.x) in samba (as of current shipping version and upcoming
4.4.x series).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/samba4/samba4.mk

index ee0452e6c232d85cffe67d441421f46e45f51e5e..0fa70a56a67af20d5940c0fab8aa27249df13a8d 100644 (file)
@@ -10,7 +10,9 @@ SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
 SAMBA4_INSTALL_STAGING = YES
 SAMBA4_LICENSE = GPLv3+
 SAMBA4_LICENSE_FILES = COPYING
-SAMBA4_DEPENDENCIES = host-e2fsprogs host-heimdal e2fsprogs popt python zlib \
+SAMBA4_DEPENDENCIES = \
+       host-e2fsprogs host-heimdal host-python \
+       e2fsprogs popt python zlib \
        $(if $(BR2_PACKAGE_LIBBSD),libbsd) \
        $(if $(BR2_PACKAGE_LIBCAP),libcap) \
        $(if $(BR2_PACKAGE_READLINE),readline)