libtpl: bump version
authorSimon Dawson <spdawson@gmail.com>
Sat, 29 Jun 2013 12:10:23 +0000 (13:10 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 2 Jul 2013 21:44:37 +0000 (23:44 +0200)
Note that libtpl has moved from sourceforge to github, and there is no longer
a version-specific tarball available.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libtpl/Config.in
package/libtpl/libtpl.mk

index a2c2c2de32b98ab85d4b30df24cec7d26a5de0e2..0286e033d69765bc256c86d72821ee97c8f1fb9a 100644 (file)
@@ -3,4 +3,4 @@ config BR2_PACKAGE_LIBTPL
        help
          Easily store and retrieve binary data in C
 
-         http://tpl.sourceforge.net/
+         http://troydhanson.github.io/tpl/
index 0016c31260fc7433ebb74487b04ceeb8a0b9a1a6..478b2989c0915f277f6b7473ac03cba878906414 100644 (file)
@@ -4,11 +4,18 @@
 #
 ################################################################################
 
-LIBTPL_VERSION = 1.5
-LIBTPL_SOURCE = libtpl-$(LIBTPL_VERSION).tar.bz2
-LIBTPL_SITE = http://downloads.sourceforge.net/project/tpl/tpl/libtpl-$(LIBTPL_VERSION)
+LIBTPL_VERSION = 445b4e9f236a48e274eaace31acf56d700da142a
+LIBTPL_SITE = http://github.com/troydhanson/tpl/tarball/$(LIBTPL_VERSION)
 LIBTPL_INSTALL_STAGING = YES
 LIBTPL_LICENSE = BSD-like
 LIBTPL_LICENSE_FILES = LICENSE
 
+LIBTPL_AUTORECONF = YES
+LIBTPL_AUTORECONF_OPT = --install --force
+
+define LIBTPL_CREATE_MISSING_FILES
+       touch $(@D)/NEWS $(@D)/AUTHORS $(@D)/ChangeLog $(@D)/COPYING
+endef
+LIBTPL_POST_EXTRACT_HOOKS += LIBTPL_CREATE_MISSING_FILES
+
 $(eval $(autotools-package))