libvips: requires C++ support
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 5 Feb 2015 15:06:56 +0000 (15:06 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 5 Feb 2015 15:58:37 +0000 (16:58 +0100)
libvips requires C++ support, otherwise it will fail with an error
message like this one:

error: ../libvips/.libs/libvips.so: No such file or directory

The '--disable-cxx' configure option seems to be broken, so in the
meantime a compiler with C++ support is required in order to build
libvips successfully.

Reported upstream:

  https://github.com/jcupitt/libvips/issues/231

Fixes:

  http://autobuild.buildroot.net/results/cdc7cf5d3501f80c74b70aa09f93b2ad4e2f8602/
  http://autobuild.buildroot.net/results/39173dbcbbd0a243900ea583cec024b51f8b803a/
  http://autobuild.buildroot.net/results/6794705195bcdb636a8e6582ef5a1e153d4d66b3/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libvips/Config.in
package/libvips/libvips.mk

index 1a0d35c5cf8b835d20344e71f08a120326c683b7..ad7a1037140e6d1f53ccac1a4e360ab4abda75d4 100644 (file)
@@ -3,6 +3,9 @@ config BR2_PACKAGE_LIBVIPS
        depends on BR2_USE_WCHAR # gettext, libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_MMU # fork()
+       # C++ support is required to build libvips
+       # https://github.com/jcupitt/libvips/issues/231
+       depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBXML2
        select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
@@ -13,6 +16,7 @@ config BR2_PACKAGE_LIBVIPS
 
          http://www.vips.ecs.soton.ac.uk/
 
-comment "libvips needs a toolchain w/ wchar, threads"
+comment "libvips needs a toolchain w/ wchar, threads, C++"
         depends on BR2_USE_MMU
-        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_INSTALL_LIBSTDCPP
index 35e7684d313fc4fcda131aae184d8db1f6983e2d..1efe21a2dfd5f2ce64c3076ca833aeb0396f4fc6 100644 (file)
@@ -33,11 +33,9 @@ LIBVIPS_DEPENDENCIES = \
        host-pkgconf libglib2 \
        libxml2 $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
 
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+# --disable-cxx is broken upstream
+# https://github.com/jcupitt/libvips/issues/231
 LIBVIPS_CONF_OPTS += --enable-cxx
-else
-LIBVIPS_CONF_OPTS += --disable-cxx
-endif
 
 ifeq ($(BR2_PACKAGE_JPEG),y)
 LIBVIPS_CONF_OPTS += --with-jpeg