wireshark: forcibly disable lua
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 2 Dec 2015 20:48:13 +0000 (17:48 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 3 Dec 2015 21:34:04 +0000 (22:34 +0100)
If host arch = target arch and liblua is in the host the buildsystem
will pick it up and try to use it since it passes basic build tests.
Forcibly disable it, since it causes no build failure, rather runtime
failures because said liblua is not present on the target.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wireshark/wireshark.mk

index 366134d563ff2c17d31c112d4ecb3257b333a934..867b94530034daf6a829966c7e6973434ffde60f 100644 (file)
@@ -26,6 +26,7 @@ WIRESHARK_CONF_OPTS = \
        --enable-static=no \
        --with-gnutls=no \
        --with-libsmi=no \
+       --with-lua=no \
        --includedir=$(STAGING_DIR)/usr/include
 
 $(eval $(autotools-package))