botan: pass --prefix=/usr to fix .pc file
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 10 Apr 2015 15:55:23 +0000 (17:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Apr 2015 20:55:00 +0000 (22:55 +0200)
botan uses a non-autotools build system. We currently don't pass any
--prefix=/usr, and by default the prefix is set to /usr/local. This
doesn't cause a lot of visible issues because at install time, we pass
DESTDIR=$(TARGET_DIR)/usr (the build system doesn't make the
difference between DESTDIR and prefix).

However, the generated pkg-config .pc file is wrong, as it contains
prefix=/usr/local instead of prefix=/usr, which doesn't match where
the botan library and headers are installed. By passing --prefix=/usr,
we make sure that the .pc file is in line with where botan is
installed.

Fixes bug #7760

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/botan/botan.mk

index 70a0946d20b9b8ed50a2862a714f8a4cf8e11702..6ac3ce7ee4594662edbe851864e64049d483b6fa 100644 (file)
@@ -16,7 +16,8 @@ BOTAN_CONF_OPTS = \
        --cpu=$(BR2_ARCH) \
        --os=linux \
        --cc=gcc \
-       --cc-bin="$(TARGET_CXX)"
+       --cc-bin="$(TARGET_CXX)" \
+       --prefix=/usr
 
 ifeq ($(BR2_STATIC_LIBS),y)
 BOTAN_CONF_OPTS += --disable-shared --no-autoload