toolchain-external: remove support for 'Sourcery CodeBench MIPS 4.4'
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Dec 2012 13:23:22 +0000 (13:23 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Dec 2012 08:22:56 +0000 (09:22 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 4104041eecdd44212792195d71e738e14e9876fd..e28da870ed7b7d49fb7fbda876eff5eac0820fd8 100644 (file)
@@ -378,56 +378,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
            - MIPS32 little endian soft float uclibc
              Not usable in Buildroot yet.
 
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
-       bool "Sourcery CodeBench MIPS 4.4"
-       depends on BR2_mips || BR2_mipsel
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Sourcery CodeBench toolchain for the MIPS architecture, from
-         Mentor Graphics. It uses gcc 4.4.1, binutils 2.19, glibc
-         2.11, uClibc 0.9.30 and gdb 7.0, kernel headers 2.6.32. It
-         has support for the following variants:
-           - MIPS32 O32 big endian glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-           - MIPS32 O32 little endian glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL
-           - MIPS32 big endian soft float glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-           - MIPS32 little endian soft float glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL
-           - MIPS32 big endian microMIPS glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mips16
-           - MIPS32 little endian microMIPS glibc
-             Select a MIPS generic core
-             Disable BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
-           - MIPS32 big endian soft float microMIPS glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mips16
-           - MIPS32 little endian soft float microMIPS glibc
-             Select a MIPS generic core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
-           - MIPS32 big endian uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 little endian uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 big endian soft float uclibc
-             Not usable in Buildroot yet.
-           - MIPS32 little endian soft float uclibc
-             Not usable in Buildroot yet.
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103
        bool "Sourcery CodeBench PowerPC 2011.03"
        depends on BR2_powerpc
@@ -773,7 +723,6 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_12_10
        default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2
        default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
-       default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203
index 2beac1d182565dc401a3e30930cc1b5497e8127b..ac639a74ce47bb7417896a98730c15aa66f80092 100644 (file)
@@ -193,9 +193,6 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_li
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.11/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.11-20121123_linux.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
-TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
-TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package9469/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.03-110-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2