package/exim: fix log and pid file paths
authorPascal de Bruijn <p.debruijn@unilogic.nl>
Mon, 2 Mar 2020 10:19:02 +0000 (11:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Apr 2020 21:05:44 +0000 (23:05 +0200)
By default, exim stores its PID file in /var/spool/exim, and its log
file in /var/spool/exim/log, but it makes a lot more sense to have the
logs in /var/log/exim and the PID file in /var/run/exim.

Using binary name subdirectory in both cases allows for the use of
systemd's LogsDirectory and RuntimeDirectory statements

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/exim/S86exim
package/exim/exim.mk
package/exim/exim.service

index bec88fc2229ac1a93edd672ae537fe1813454873..0d09361f6548e8972e61aa4a519b13b634c61e9d 100644 (file)
@@ -3,11 +3,19 @@
 # Start/stop exim
 #
 
-PIDFILE=/var/lock/exim/exim-daemon.pid
+PIDFILE=/var/run/exim/exim.pid
 
 case "$1" in
   start)
        echo "Starting exim..."
+       if [ ! -d /var/log/exim ]; then
+         mkdir -p /var/log/exim
+         chown exim:mail /var/log/exim
+       fi
+       if [ ! -d /var/run/exim ]; then
+         mkdir -p /var/run/exim
+         chown root:mail /var/run/exim
+       fi
        start-stop-daemon -S -x exim -- -bd
        ;;
   stop)
index e4b0bfc1b4881911360468444f2ebd0e411cf14b..8d5b6e415b62aadd66340862e8155e71aabd5f6c 100644 (file)
@@ -39,6 +39,8 @@ define EXIM_USE_DEFAULT_CONFIG_FILE
        $(INSTALL) -m 0644 $(@D)/src/EDITME $(@D)/Local/Makefile
        $(call exim-config-change,BIN_DIRECTORY,/usr/sbin)
        $(call exim-config-change,CONFIGURE_FILE,/etc/exim/configure)
+       $(call exim-config-change,LOG_FILE_PATH,/var/log/exim/exim_%slog)
+       $(call exim-config-change,PID_FILE_PATH,/var/run/exim/exim.pid)
        $(call exim-config-change,EXIM_USER,ref:exim)
        $(call exim-config-change,EXIM_GROUP,mail)
        $(call exim-config-change,TRANSPORT_LMTP,yes)
index fe97727ab51552ec0cab330ab44c6eb64af7327b..ac3f067de468f0e9d1f9e78f1fd493d5c7228c3c 100644 (file)
@@ -3,6 +3,10 @@ Description=Exim MTA
 After=syslog.target network.target
 
 [Service]
+User=exim
+Group=mail
+LogsDirectory=exim
+RuntimeDirectory=exim
 ExecStart=/usr/sbin/exim -bdf
 Restart=always