luajit: point /usr/bin/lua to luajit if lua not selected
authorDanomi Manchego <danomimanchego123@gmail.com>
Sun, 30 Nov 2014 18:46:12 +0000 (13:46 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 30 Nov 2014 22:11:29 +0000 (23:11 +0100)
The luajit package is a provider of a lua interpreter, but does not install a
lua executable.  This is fine for scripts that explicitly invoke luajit, but
not so good for scripts that just need a lua interpreter and call lua.  This
mod creates a lua symlink so that the non-jit-specific scripts will still work.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/luajit/luajit.mk

index 2c1f8f4ed155ef1493913a8663053b2197757acc..85e9f1528e9abe5ec2e7479db8163f4230ccbcc4 100644 (file)
@@ -64,6 +64,11 @@ define LUAJIT_INSTALL_TARGET_CMDS
        $(MAKE) PREFIX="/usr" DESTDIR="$(TARGET_DIR)" LDCONFIG=true -C $(@D) install
 endef
 
+define LUAJIT_INSTALL_SYMLINK
+       ln -fs luajit $(TARGET_DIR)/usr/bin/lua
+endef
+LUAJIT_POST_INSTALL_TARGET_HOOKS += LUAJIT_INSTALL_SYMLINK
+
 define HOST_LUAJIT_BUILD_CMDS
        $(MAKE) PREFIX="/usr" BUILDMODE=static -C $(@D) amalg
 endef