qt: make $(HOST_DIR)/usr/mkspecs a symlink to $(STAGING_DIR)/usr/mkspecs
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jun 2012 06:13:59 +0000 (06:13 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jun 2012 20:50:26 +0000 (22:50 +0200)
In fact, not only qt can install stuff in $(STAGING_DIR)/usr/mkspecs,
but also libraries that wish to integrate with qmake, such as
qwt. However, qmake and al. will look inside $(HOST_DIR)/usr/mkspecs,
so the easiest solution is to have a symbolic link between the two
directories, instead of copying things around.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 7e6c5dd25a74cbee76fc971292819bee370f873c..b7516963602f18a8973fa2c1fa2ab54d1008a17d 100644 (file)
@@ -583,8 +583,7 @@ define QT_INSTALL_STAGING_CMDS
        $(MAKE) -C $(@D) install
        mkdir -p $(HOST_DIR)/usr/bin
        mv $(addprefix $(STAGING_DIR)/usr/bin/,$(QT_HOST_PROGRAMS)) $(HOST_DIR)/usr/bin
-       rm -rf $(HOST_DIR)/usr/mkspecs
-       mv $(STAGING_DIR)/usr/mkspecs $(HOST_DIR)/usr
+       ln -sf $(STAGING_DIR)/usr/mkspecs $(HOST_DIR)/usr/mkspecs
        $(QT_INSTALL_QT_CONF)
 endef