sdl: Fix missing autoconf
authorClayton Shotwell <clshotwe@rockwellcollins.com>
Fri, 10 Jan 2014 13:38:43 +0000 (07:38 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Jan 2014 14:00:48 +0000 (15:00 +0100)
Fixing an issue seen on the autobuilders with sdl failing to run the
autogen.sh script. Several of the autobuild issues are listed below.

http://autobuild.buildroot.net/results/7326631048bc9e15ffadc6f541f2235592b5259b/
http://autobuild.buildroot.net/results/0adf5ea64075323eba1183f93c16d2954673f3e1/

Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl/sdl.mk

index a30a31eea5b986bf2eb433eb124bc07783ee3859..ba5fbca020da69c6df421cf8a3676c0ff51e0d79 100644 (file)
@@ -14,7 +14,7 @@ SDL_INSTALL_STAGING = YES
 # we're patching configure.in, but package cannot autoreconf with our version of
 # autotools, so we have to do it manually instead of setting SD_AUTORECONF = YES
 define SDL_RUN_AUTOGEN
-       cd $(@D) && ./autogen.sh
+       cd $(@D) && PATH=$(HOST_PATH) ./autogen.sh
 endef
 
 SDL_POST_PATCH_HOOKS += SDL_RUN_AUTOGEN