package/sshfs: bump to version 3.7.1
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 12 Nov 2020 22:16:30 +0000 (23:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 13 Nov 2020 18:08:26 +0000 (19:08 +0100)
Drop patch (already in version)

https://github.com/libfuse/sshfs/blob/sshfs-3.7.1/ChangeLog.rst

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sshfs/0001-sshfs.c-fix-build-with-gcc-4.8.patch [deleted file]
package/sshfs/sshfs.hash
package/sshfs/sshfs.mk

diff --git a/package/sshfs/0001-sshfs.c-fix-build-with-gcc-4.8.patch b/package/sshfs/0001-sshfs.c-fix-build-with-gcc-4.8.patch
deleted file mode 100644 (file)
index 312985d..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From 35ff9ed71b89f34e5462de1ee63f88edf98aeb69 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sat, 31 Oct 2020 21:08:53 +0100
-Subject: [PATCH] sshfs.c: fix build with gcc 4.8
-
-Fix the following build failure with gcc 4.8:
-
-../sshfs.c:1092:2: error: 'for' loop initial declarations are only allowed in C99 mode
-  for (int i = 0; i < sshfs.max_conns; i++) {
-  ^
-
-This build failure has been added with
-https://github.com/libfuse/sshfs/commit/8822b60d9dbd9907065e7999f616b11ddce6d584
-
-Fixes:
- - http://autobuild.buildroot.org/results/2dbdc579c55543175716d5f739cabe2ad0864ed6
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: https://github.com/libfuse/sshfs/pull/233]
----
- sshfs.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/sshfs.c b/sshfs.c
-index d5f2ff7..2c2db42 100644
---- a/sshfs.c
-+++ b/sshfs.c
-@@ -1068,6 +1068,7 @@ static struct conn* get_conn(const struct sshfs_file *sf,
-                            const char *path)
- {
-       struct conntab_entry *ce;
-+      int i;
-       if (sshfs.max_conns == 1)
-               return &sshfs.conns[0];
-@@ -1089,7 +1090,7 @@ static struct conn* get_conn(const struct sshfs_file *sf,
-       int best_index = 0;
-       uint64_t best_score = ~0ULL; /* smaller is better */
--      for (int i = 0; i < sshfs.max_conns; i++) {
-+      for (i = 0; i < sshfs.max_conns; i++) {
-               uint64_t score = ((uint64_t) sshfs.conns[i].req_count << 43) +
-                                ((uint64_t) sshfs.conns[i].dir_count << 22) +
-                                ((uint64_t) sshfs.conns[i].file_count << 1) +
--- 
-2.28.0
-
index b8488013a72b159aa3bb5b9cebe88ba26d837802..106f06f09ff05221f4780a5c2d9c5208fbc6c65e 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated after checking pgp signature
-sha256  6e7e86831f3066b356e7f16e22f1b8a8f177fda05146f6a5eb821c2fd0541c34  sshfs-3.7.0.tar.xz
+sha256  fe5d3436d61b46974889e0c4515899c21a9d67851e3793c209989f72353d7750  sshfs-3.7.1.tar.xz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
index 70e7feab1d212eaad5e9a0b3824b7aac0165a423..6759f6ab3be575958047d42b76dceb91793a3ab0 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-SSHFS_VERSION = 3.7.0
+SSHFS_VERSION = 3.7.1
 SSHFS_SOURCE = sshfs-$(SSHFS_VERSION).tar.xz
 SSHFS_SITE = https://github.com/libfuse/sshfs/releases/download/sshfs-$(SSHFS_VERSION)
 SSHFS_LICENSE = GPL-2.0