foomatic-filters: remove deprecated
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 11 Mar 2016 14:32:20 +0000 (11:32 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 15 Mar 2016 21:45:31 +0000 (22:45 +0100)
It's been deprecated for a year now so remove it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/foomatic-filters/Config.in [deleted file]
package/foomatic-filters/foomatic-filters.mk [deleted file]

index 828d0acb6f78dc1c24d2f54f3db3f51bc22fb4b6..e03e30fb0e4f87f234986e25f8897f51ef82a0af 100644 (file)
@@ -145,6 +145,12 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_PACKAGE_FOOMATIC_FILTERS
+       bool "foomatic-filters"
+       select BR2_LEGACY
+       help
+         The foomatic-filters package was removed.
+
 config BR2_PACKAGE_SAMBA
        bool "samba"
        select BR2_LEGACY
index 16e495725e588cfcce314094b621aee2169c9234..2401867f537f3f5ab5ed1bef7e22b72d55265d61 100644 (file)
@@ -1365,7 +1365,6 @@ endif
        source "package/fastd/Config.in"
        source "package/fcgiwrap/Config.in"
        source "package/fmc/Config.in"
-       source "package/foomatic-filters/Config.in"
        source "package/fping/Config.in"
        source "package/gesftpserver/Config.in"
        source "package/gutenprint/Config.in"
diff --git a/package/foomatic-filters/Config.in b/package/foomatic-filters/Config.in
deleted file mode 100644 (file)
index 0571eb9..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-comment "foomatic-filters needs a toolchain w/ threads"
-       # because of cups security issues
-       depends on BR2_DEPRECATED_SINCE_2015_05
-       depends on BR2_PACKAGE_CUPS
-       depends on !BR2_TOOLCHAIN_HAS_THREADS
-
-config BR2_PACKAGE_FOOMATIC_FILTERS
-       bool "foomatic_filters"
-       depends on BR2_PACKAGE_CUPS
-       # because of cups security issues
-       depends on BR2_DEPRECATED_SINCE_2015_05
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
-       select BR2_PACKAGE_LIBUSB
-       select BR2_PACKAGE_ENSCRIPT
-       help
-         Foomatic Filters
-         Foomatic is a database-driven system for integrating free software
-         printer drivers with common spoolers under Unix. It supports CUPS,
-         LPRng, LPD, GNUlpr, Solaris LP, PPR, PDQ, CPS, and direct printing
-         with every free software printer driver known to us and every
-         printer known to work with these drivers.
-
-         http://www.linuxfoundation.org/collaborate/workgroups/openprinting/database/foomatic
diff --git a/package/foomatic-filters/foomatic-filters.mk b/package/foomatic-filters/foomatic-filters.mk
deleted file mode 100644 (file)
index c7d6298..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-################################################################################
-#
-# foomatic-filters
-#
-################################################################################
-
-FOOMATIC_FILTERS_VERSION = 4.0.17
-FOOMATIC_FILTERS_SITE = http://www.openprinting.org/download/foomatic
-FOOMATIC_FILTERS_LICENSE = GPLv2+
-FOOMATIC_FILTERS_LICENSE_FILES = COPYING
-FOOMATIC_FILTERS_DEPENDENCIES = cups libusb enscript
-FOOMATIC_FILTERS_CONF_OPTS = --with-file-converter=enscript
-FOOMATIC_FILTERS_CONF_ENV = ac_cv_path_ENSCRIPT="/usr/bin/enscript"
-
-ifeq ($(BR2_PACKAGE_DBUS),y)
-FOOMATIC_FILTERS_CONF_OPTS += --enable-dbus
-FOOMATIC_FILTERS_DEPENDENCIES += dbus
-else
-FOOMATIC_FILTERS_CONF_OPTS += --disable-dbus
-endif
-
-$(eval $(autotools-package))