toolchain/gcc-3.x: strip cross libgcc / libstdc++ with cross-strip, not host.
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Jun 2008 12:54:36 +0000 (12:54 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Jun 2008 12:54:36 +0000 (12:54 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk

index 58afa926144cf6e8817c7557553bb264f6b735ee..cc4bcadb2196c7d6fe974995842ad6b8676daff3 100644 (file)
@@ -336,12 +336,12 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
        rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
        -cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* \
                $(TARGET_DIR)/lib/
-       -strip --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
+       -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
 endif
 ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
        -cp -dpf $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/usr/lib/
-       -strip --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
+       -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
 endif
 endif
 ifeq ($(BR2_INSTALL_LIBGCJ),y)