php: switch to pcre2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 16 Jan 2019 21:00:16 +0000 (22:00 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 19 Jan 2019 21:33:57 +0000 (22:33 +0100)
php moved from pcre to pcre2 since bump to version 7.3 and
http://github.com/php/php-src/commit/a5bc5aed71f7a15f14f33bb31b8e17bf5f327e2d

This fixes a build failure: without this change, if BR2_PACKAGE_PCRE is
set, external pcre support in php is (wrongly) enabled with
--with-pcre-regex but because pcre2 was not found, php fallbacks on
built-in pcre2 without the "SLJIT_SINGLE_THREADED hack"

Fixes:
 - http://autobuild.buildroot.org/results/40ef339019203d2cc49d388e222cf17c3ca37944

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index fd428e192a4a4537bf58dbbce797e79b1b1244b7..b6b17a1562f30cb543048102dc47a92e085739f4 100644 (file)
@@ -243,9 +243,9 @@ endef
 PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
 
 ### Use external PCRE if it's available
-ifeq ($(BR2_PACKAGE_PCRE),y)
+ifeq ($(BR2_PACKAGE_PCRE2),y)
 PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
-PHP_DEPENDENCIES += pcre
+PHP_DEPENDENCIES += pcre2
 else
 # The bundled pcre library is not configurable through ./configure options,
 # and by default is configured to be thread-safe, so it wants pthreads. So