fakeroot: disallow selection for the target
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 May 2011 11:56:08 +0000 (13:56 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 May 2011 13:54:34 +0000 (15:54 +0200)
fakeroot for the target fails to build against glibc, due to largefile
related problems :

libtool: link: /home/test/outputs/test-503/host/usr/bin/powerpc-linux-gnu-gcc -pipe -Os -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o faked faked.o  ./.libs/libcommunicate.a -ldl
{standard input}: Assembler messages:
{standard input}:2592: Error: symbol `__fxstatat64' is already defined
{standard input}:2627: Error: symbol `__fxstat64' is already defined
{standard input}:2663: Error: symbol `__xstat64' is already defined
{standard input}:2698: Error: symbol `__lxstat64' is already defined
make[3]: *** [libfakeroot.lo] Error 1

As fakeroot for the target is not really needed, and was only added
when we packaged fakeroot for the host, just make fakeroot not
selectable for the target.

We have to keep the AUTOTARGETS call for fakeroot on the target,
because the host variant does not work otherwise, due to issues in the
package infrastructure (that will be fixed post-2011.05).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/fakeroot/Config.in [deleted file]
package/fakeroot/fakeroot.mk

index 1d3c0ccbb513900f2d57cce03d5a9d8b912b114f..40f523de25493e7fbbd6e5201f7d0970e2bd711e 100644 (file)
@@ -48,7 +48,6 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/diffutils/Config.in"
 endif
 source "package/distcc/Config.in"
-source "package/fakeroot/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/findutils/Config.in"
 endif
diff --git a/package/fakeroot/Config.in b/package/fakeroot/Config.in
deleted file mode 100644 (file)
index 186b717..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-config BR2_PACKAGE_FAKEROOT
-       bool "fakeroot"
-       help
-         Run commands in an environment faking root privileges.
-
-         http://joostje.op.het.net/fakeroot/
index 8061443d78e94e9b394f21a7e2884d402077907d..29e9e5beb68ef94507d88e1881e369e9b385496d 100644 (file)
@@ -16,5 +16,8 @@ endef
 
 FAKEROOT_POST_PATCH_HOOKS += FAKEROOT_PATCH_FAKEROOT_IN
 
+# The package for the target cannot be selected (build problems when
+# largefile is enabled), but is needed for the host package to work
+# due to deficiencies in the package infrastructure.
 $(eval $(call AUTOTARGETS,package,fakeroot))
 $(eval $(call AUTOTARGETS,package,fakeroot,host))