package/mono: fixing wrong monolite library path
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Sun, 30 Nov 2014 21:41:06 +0000 (22:41 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 30 Nov 2014 22:51:28 +0000 (23:51 +0100)
Due to a bug in makefile logic, monolite libraries path will not
be selected when EXTERNAL_MCS parameter is specified.
Setting EXTERNAL_MCS to a non existent binary, makes the internal logic
to fallback to monolite, setting correctly both binary and
library paths.
This has the benefit to force host-mono to always use monolite as
bootstrap compiler also in case a mono compiler is already installed
on the system.

Fixes:
http://autobuild.buildroot.net/results/fc00952bef03cf3b4785be1a0d9c08dc84aa3f54/

[Peter: add comment explaining why this is done]
Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Reported-by: Rainer Berns <rainer.berns@berns-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mono/mono.mk

index df67c336bad8ba932e64bbbf3875cd5083652010..baf205a275308e232f6b74a79097d9331b82cc0a 100644 (file)
@@ -55,7 +55,8 @@ HOST_MONO_CONF_OPTS += \
        --with-profile4=$(if $(BR2_PACKAGE_MONO_40),yes,no) \
        --with-profile4_5=$(if $(BR2_PACKAGE_MONO_45),yes,no)
 
-HOST_MONO_MAKE_OPTS += EXTERNAL_MCS="$(@D)/mcs/class/lib/monolite/basic.exe"
+# ensure monolite is used
+HOST_MONO_MAKE_OPTS += EXTERNAL_MCS=false
 
 HOST_MONO_DEPENDENCIES = host-monolite host-gettext