ruby: use --disable-rubygems
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 1 Oct 2014 22:39:56 +0000 (19:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 2 Oct 2014 10:06:39 +0000 (12:06 +0200)
At least for ruby 2.x we need to --disable-rubygems besides removing the
gems files to avoid the requires.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ruby/ruby.mk

index 8c094b5ccfb0a1c687f7a82e01d574c5c1c06cd6..bf341899ca15a504fa63f1e05ff9b717c1f49df8 100644 (file)
@@ -12,7 +12,7 @@ RUBY_DEPENDENCIES = host-pkgconf host-ruby
 HOST_RUBY_DEPENDENCIES = host-pkgconf
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_MAKE = $(MAKE1)
-RUBY_CONF_OPT = --disable-install-doc --disable-rpath
+RUBY_CONF_OPT = --disable-install-doc --disable-rpath --disable-rubygems
 HOST_RUBY_CONF_OPT = --disable-install-doc \
        --with-out-ext=curses,openssl,readline \
        --without-gmp