- put dependency checking right to the start where any later stages can rely on the...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 27 Jul 2007 15:10:45 +0000 (15:10 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 27 Jul 2007 15:10:45 +0000 (15:10 -0000)
Makefile
toolchain/uClibc/uclibc.mk

index 8cf088821154282e926cff031f4f29a0cc962775..cf1593d89b4177c0e726e0ebbba40595c1005a36 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -213,7 +213,7 @@ $(TARGETS): $(BASE_TARGETS)
 dirs: $(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
        $(BINARIES_DIR) $(PROJECT_BUILD_DIR)
 $(BASE_TARGETS): dirs
-world: dirs target-host-info $(TARGETS)
+world: dependencies dirs target-host-info $(TARGETS)
 
 
 .PHONY: all world dirs clean dirclean distclean source target-host-info \
index 256d2ee704ca90d437eaebe02673e455bb7532fc..54d788f7d1b63aaef44d1c3866baf9a42141d043 100644 (file)
@@ -359,7 +359,7 @@ endif
 UCLIBC_TARGETS=$(TARGET_DIR)/lib/libc.so.0
 endif
 
-uclibc-configured: dependencies kernel-headers $(UCLIBC_DIR)/.configured
+uclibc-configured: kernel-headers $(UCLIBC_DIR)/.configured
 
 
 uclibc: $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc $(STAGING_DIR)/usr/lib/libc.a $(UCLIBC_TARGETS)