util-linux: disable systemd support
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 22 Oct 2015 20:36:50 +0000 (22:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 22 Oct 2015 20:42:33 +0000 (22:42 +0200)
Fixes (works around) #8421

Util-linux has optional systemd support, but we cannot enable it as systemd
depends on util-linux, so that would create a circular dependency.

The systemd unit directory location detection also fails as pkg-config
0.9.12+ prefixes all directory variables with the sysroot, and the configure
script expects to see the target location, so disable that as well for good
measure.

The systemd support doesn't seem to add much, so it isn't a big loss.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/util-linux/util-linux.mk

index 27d22cb413e073e7e3eddc8a2181f6a3de09b6db..39ba5441f5fbe619582e904283e59d868d11f0ea 100644 (file)
@@ -26,6 +26,12 @@ UTIL_LINUX_CONF_OPTS += \
        --disable-makeinstall-chown \
        --without-python
 
+# system depends on util-linux so we enable systemd support
+# (which needs systemd to be installed)
+UTIL_LINUX_CONF_OPTS += \
+       --without-systed \
+       --with-systemdsystemunitdir=no
+
 # We don't want the host-busybox dependency to be added automatically
 HOST_UTIL_LINUX_DEPENDENCIES = host-pkgconf