package/libcpprestsdk: fix static build with boost 1.70.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 17 Apr 2019 21:00:50 +0000 (23:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 21 Apr 2019 10:23:07 +0000 (12:23 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/36ef83aefd24bcc6bbf58812aa07aa0f6072cd09

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libcpprestsdk/libcpprestsdk.mk

index cd48ca7bedd5b6f42a76116a8631a5da4feb47a1..e8dddeddd7ce8d6d9bb257910115e3d35d74cb77 100644 (file)
@@ -12,6 +12,12 @@ LIBCPPRESTSDK_SUBDIR = Release
 LIBCPPRESTSDK_DEPENDENCIES += host-pkgconf boost openssl zlib
 LIBCPPRESTSDK_CONF_OPTS = -DWERROR=OFF -DBUILD_SAMPLES=OFF
 
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBCPPRESTSDK_CONF_OPTS += \
+       -DBoost_USE_STATIC_LIBS=ON \
+       -DBoost_USE_STATIC_RUNTIME=ON
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 LIBCPPRESTSDK_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
 endif