core: simplify removal of generated br2-external files
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 29 Jul 2019 20:19:55 +0000 (22:19 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Aug 2019 19:51:40 +0000 (21:51 +0200)
Now that all the br2-external generated files are named after the same
pattern, it gets easier to remove them all using a glob.

Furthermore, we're on the verge of introducing more such generated
files, so removing them at one fell swoop will be simpler too.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 8bca4bafd0e22077ffcb0331af2a9e872a033b6d..24cb6be85eb0d2f59e20b6253720eda592972b2e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1066,7 +1066,7 @@ ifeq ($(O),$(CURDIR)/output)
        rm -rf $(O)
 endif
        rm -rf $(TOPDIR)/dl $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
-               $(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE) $(BASE_DIR)/.br2-external.in
+               $(CONFIG_DIR)/.auto.deps $(BASE_DIR)/.br2-external.*
 
 .PHONY: help
 help: