Fix <PKG_NAME>_VERSION variable setup
authorLionel Landwerlin <llandwerlin@gmail.com>
Sat, 18 Sep 2010 23:21:15 +0000 (01:21 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 20 Sep 2010 14:24:54 +0000 (16:24 +0200)
Commit 993e51bc22f508fbaf39c5c49fd0595fc5c56013 introduced a problem
to compute <PKG_NAME>_VERSION variable when PKG_NAME start with
'HOST_'.

Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index 58a9a51dc5c5a00537cb7954bbb603ace14fbc03..377df65c0b08d085134147f1dc0b0553fc7420c6 100644 (file)
@@ -337,22 +337,22 @@ define GENTARGETS_INNER
 $(2)_TYPE                       =  $(5)
 $(2)_NAME                      =  $(1)
 
+# Keep the package version that may contain forward slashes in the _DL_VERSION
+# variable, then replace all forward slashes ('/') by underscores ('_') to
+# sanitize the package version that is used in paths, directory and file names.
+# Forward slashes may appear in the package's version when pointing to a
+# version control system branch or tag, for example remotes/origin/1_10_stable.
+$(2)_DL_VERSION        = $($(2)_VERSION)
 ifndef $(2)_VERSION
  ifdef $(3)_VERSION
   $(2)_VERSION = $($(3)_VERSION)
  else
   $(2)_VERSION = undefined
  endif
+else
+ $(2)_VERSION = $(subst /,_,$($(2)_VERSION))
 endif
 
-# Keep the package version that may contain forward slashes in the _DL_VERSION
-# variable, then replace all forward slashes ('/') by underscores ('_') to
-# sanitize the package version that is used in paths, directory and file names.
-# Forward slashes may appear in the package's version when pointing to a
-# version control system branch or tag, for example remotes/origin/1_10_stable.
-$(2)_DL_VERSION        = $($(2)_VERSION)
-$(2)_VERSION = $(subst /,_,$($(2)_VERSION))
-
 $(2)_BASE_NAME =  $(1)-$$($(2)_VERSION)
 $(2)_DL_DIR    =  $$(DL_DIR)/$$($(2)_BASE_NAME)
 $(2)_DIR       =  $$(BUILD_DIR)/$$($(2)_BASE_NAME)