python-falcon: add optional dependency on host-python-cython
authorGrzegorz Blach <grzegorz@blach.pl>
Thu, 30 Aug 2018 10:18:47 +0000 (12:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Sep 2018 12:58:38 +0000 (14:58 +0200)
Falcon can be compiled into shared objects using Cython.
Compiled version works much faster than pure-python one.

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-falcon/python-falcon.mk

index 106387f96f7f5361d56540f671ddad26e7b684cf..b724ffadbeb9da451360202803f7a25761d7a4e3 100644 (file)
@@ -11,4 +11,8 @@ PYTHON_FALCON_SETUP_TYPE = setuptools
 PYTHON_FALCON_LICENSE = Apache-2.0
 PYTHON_FALCON_LICENSE_FILES = LICENSE
 
+ifeq ($(BR2_PACKAGE_HOST_PYTHON_CYTHON),y)
+PYTHON_FALCON_DEPENDENCIES += host-python-cython
+endif
+
 $(eval $(python-package))