package/wlroots: bump to version 0.13.0
authorAdrian Perez de Castro <aperez@igalia.com>
Tue, 18 May 2021 13:54:19 +0000 (16:54 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 18 May 2021 16:55:21 +0000 (18:55 +0200)
Update wlroots to version 0.13.0. This is a release which changes
API/ABI, applications which use wlroots need to be rebuilt. Currently in
Buildroot there is only cage, to be updated by a follow-up patch of the
series.

Additionally, remove usage of the xcb-icccm build option, which is no
longer available and update the dependencies needed by the X11 support.
Note that the dependencies neded by the X11 backend are a superset of
the ones needed for XWayland support, so we can make toggle both Meson
options at once.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/wlroots/Config.in
package/wlroots/wlroots.hash
package/wlroots/wlroots.mk

index 694aa79de4d05ef3d6a0a56ff21d5153173d4a78..41f8986772c25fa3a93559807ed47d1dcf10421b 100644 (file)
@@ -33,6 +33,9 @@ if BR2_PACKAGE_WLROOTS
 config BR2_PACKAGE_WLROOTS_X11
        bool "X11 backend"
        depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_LIBXCB
+       select BR2_PACKAGE_XCB_UTIL_RENDERUTIL
+       select BR2_PACKAGE_XCB_UTIL_WM
        select BR2_PACKAGE_XLIB_LIBX11
        help
          Support Wayland sessions nested inside a X11 window
index 2fab9b30b4e071724c3af3e5c661a345ccf1ff94..024ea93caee8f5bcb9caa62f3090d9d1ffdf40cf 100644 (file)
@@ -1,5 +1,5 @@
-# Generated locally, after checking https://github.com/swaywm/wlroots/releases/download/0.12.0/wlroots-0.12.0.tar.gz.sig
-sha256  c9e9f4f6d2f526d0b2886daf3ec37e64831773059aa669fb98a88522a1626bdb  wlroots-0.12.0.tar.gz
+# Generated locally, after checking https://github.com/swaywm/wlroots/releases/download/0.13.0/wlroots-0.13.0.tar.gz.sig
+sha256  f6bea37fd4a6f5e5f552b83d61adae8c73e64b0bcb9ae0ab464ebcd9309d3cf3  wlroots-0.13.0.tar.gz
 
 # Hashes for license files:
 sha256  ffd3737a478b83a8b51b42757d3bf909ef36694508355879722e11fc1fa6736b  LICENSE
index 0160b1aedbb4afe6466fae3595b6af5a36206013..a20f6683a96404c74ba85519cf9b37c2f7904b39 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-WLROOTS_VERSION = 0.12.0
+WLROOTS_VERSION = 0.13.0
 WLROOTS_SITE = https://github.com/swaywm/wlroots/releases/download/$(WLROOTS_VERSION)
 WLROOTS_LICENSE = MIT
 WLROOTS_LICENSE_FILES = LICENSE
@@ -40,24 +40,10 @@ WLROOTS_CONF_OPTS += -Dlogind=disabled
 endif
 
 ifeq ($(BR2_PACKAGE_WLROOTS_X11),y)
-WLROOTS_CONF_OPTS += -Dx11-backend=enabled
-WLROOTS_DEPENDENCIES += xlib_libX11
+WLROOTS_CONF_OPTS += -Dx11-backend=enabled -Dxwayland=enabled
+WLROOTS_DEPENDENCIES += libxcb xcb-util-wm xcb-util-renderutil xlib_libX11
 else
-WLROOTS_CONF_OPTS += -Dx11-backend=disabled
-endif
-
-ifeq ($(BR2_PACKAGE_LIBXCB),y)
-WLROOTS_CONF_OPTS += -Dxwayland=enabled
-WLROOTS_DEPENDENCIES += libxcb
-else
-WLROOTS_CONF_OPTS += -Dxwayland=disabled
-endif
-
-ifeq ($(BR2_PACKAGE_XCB_UTIL_WM),y)
-WLROOTS_CONF_OPTS += -Dxcb-icccm=enabled
-WLROOTS_DEPENDENCIES += xcb-util-wm
-else
-WLROOTS_CONF_OPTS += -Dxcb-icccm=disabled
+WLROOTS_CONF_OPTS += -Dx11-backend=disabled -Dxwayland=disabled
 endif
 
 $(eval $(meson-package))