utils/check-package: ignore ACLOCAL_PATH
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 4 Feb 2020 16:15:19 +0000 (17:15 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 4 Feb 2020 16:15:19 +0000 (17:15 +0100)
The aclocal program is provided by the automake package, so it makes
sense to define aclocal-related variables in automake.mk.

Add an exception to check-package to ignore that variable.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
utils/checkpackagelib/lib_mk.py

index b805cd9925288917de696db3a47f19e312ed520a..a0caf846364fe178cc24fb90f2581b2ff6eb68cd 100644 (file)
@@ -225,6 +225,7 @@ class TypoInPackageVariable(_CheckFunction):
     ALLOWED = re.compile("|".join([
         "ACLOCAL_DIR",
         "ACLOCAL_HOST_DIR",
+        "ACLOCAL_PATH",
         "BR_CCACHE_INITIAL_SETUP",
         "BR_LIBC",
         "BR_NO_CHECK_HASH_FOR",