package: normalize output of 'make external-deps'
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 29 Sep 2011 19:57:51 +0000 (21:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Sep 2011 06:26:08 +0000 (08:26 +0200)
For wget-downloaded packages, only the tarball name was displayed,
while for svn/git/bzr packages, the complete repository URL was
shown. As discussed on the list, what we want for 'make external-deps'
is only the tarball name even for git/svn/bzr downloads.

For local packages, we of course keep the full path since it's the
only information that we can provide.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index 10212061f93a4d6d49f83bee75e7b5ca11359b96..353ba72a0331386186c37d4c157555648ff6af72 100644 (file)
@@ -141,7 +141,7 @@ define SOURCE_CHECK_GIT
 endef
 
 define SHOW_EXTERNAL_DEPS_GIT
-  echo "$($(PKG)_SITE) [git: $($(PKG)_DL_VERSION)]"
+       echo $($(PKG)_SOURCE)
 endef
 
 
@@ -155,7 +155,7 @@ define SOURCE_CHECK_BZR
 endef
 
 define SHOW_EXTERNAL_DEPS_BZR
-       echo "$($(PKG)_SITE) [bzr: $($(PKG)_DL_VERSION)]"
+       echo $($(PKG)_SOURCE)
 endef
 
 
@@ -173,7 +173,7 @@ define SOURCE_CHECK_SVN
 endef
 
 define SHOW_EXTERNAL_DEPS_SVN
-  echo "$($(PKG)_SITE) [svn: $($(PKG)_DL_VERSION)]"
+  echo $($(PKG)_SOURCE)
 endef